WordPress 1.5 在 wp-rss2.php 的 bug

最近時間實在不多,所以說真的,實在很不想花時間處理像這樣的事情。而才剛升級到 WordPress 1.5 ,居然就發現了一個嚴重的缺陷,那就是,如果你在 WordPress 1.5 上套用了英文語系以外的語系檔案(例如中文化),那麼 RSS2 的feed就會爛掉,原因是 WP 1.5 會把 RSS2 當中的日期語法,如月份、星期幾等,也一併換成語系檔案中的字串,而造成各種 RSS 閱讀軟體無法閱讀。

解決的方法是要改一下 wp-rss2.php 這個檔案,找一下第 36 行,把:

<pubDate><?php echo mysql2date('D, d M Y H:i:s +0000', get_the_time('Y-m-d H:i:s')); ?></pubDate>

改成

<pubDate><?php echo mysql2date('D, d M Y H:i:s +0000', get_the_time('Y-m-d H:i:s'), 0); ?></pubDate>

相關討論可以參見:

RSS2 feed does not validate when using translation mo file
wp-rss2.php broken after localization

Be Sociable, Share!

13 thoughts on “WordPress 1.5 在 wp-rss2.php 的 bug

  1. Pingback: Anson’s Blah Blah Blah » Blog Archive » Upgrading WordPress

  2. Pingback: ChinLung’s Blog » Blog Archive » Wordpress 1.5

  3. 和4樓完全一樣的情況 XD
    剛剛才回想到有Sage這東西,訂閱之後觀看直接出現下面的訊息
    Error: XML 分析錯誤

  4. 請問zonble,

    如果透過bloglines訂閱我自己的blog,會發現不少多餘的rss feed(像是分類的feed),請問我該如何修改才能刪除它們 or 使它們不被訂閱?

    謝謝!

  5. Pingback: William’s Blog » Blog Archive » WordPress 升級至 1.5.1

  6. Pingback: » Blog Archive » 系統升級

  7. Pingback: Lisrel@Bad Sector » Blog Archive » 升級1.5

  8. Pingback: siko Blog » WordPress 1.5 在 wp-rss2.php 的 bug - 『轉載』

  9. Pingback: WordPress 1.5 upgrade to 1.5.1 « Khwooo’s Weblog

Comments are closed.